Point Class |
The Point class represents a single position in 3D space.
Inheritance Hierarchy
SystemObject
Tekla.Structures.Geometry3dPoint
Tekla.Structures.CatalogsCrossSectionPoint
Tekla.Structures.Geometry3dVector
Tekla.Structures.ModelContourPoint
Tekla.Structures.Geometry3dPoint
Tekla.Structures.CatalogsCrossSectionPoint
Tekla.Structures.Geometry3dVector
Tekla.Structures.ModelContourPoint
Namespace: Tekla.Structures.Geometry3d
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
The Point type exposes the following members.
Constructors
Name | Description | |
---|---|---|
Point |
Instantiates a point with zero members.
| |
Point(Point) |
Instantiates a point with the given other point.
| |
Point(Double, Double) |
Instantiates a point with the given coordinates and zero Z-coordinate.
| |
Point(Double, Double, Double) |
Instantiates a point with the given coordinates.
|
Methods
Name | Description | |
---|---|---|
AreEqual |
Compares two points and tells whether they are equal.
| |
CompareTo |
Compares two points. To use binarysearch somekind of sorting should be used.
| |
Equals |
Returns true if the current object and the given object are equal.
(Overrides ObjectEquals(Object).) | |
GetHashCode |
Returns a hash code for the point.
Notice, in extremely rare cases, you might not get the same
hash code for two points even though they are considered equal! This
should, however, happen only in extremely rare cases!
(Overrides ObjectGetHashCode.) | |
ToString |
Formats the point into a string.
(Overrides ObjectToString.) | |
Translate |
Translates the point using the given vector.
| |
Zero |
Zeros all the members of the point.
|
Operators
Name | Description | |
---|---|---|
Addition |
Returns the sum of the given two points.
| |
Equality |
Compares the given two points for similarity.
| |
Inequality |
Compares if the two given points are not similar.
| |
Subtraction |
Returns the difference of the given two points.
|
Fields
Name | Description | |
---|---|---|
EPSILON_SQUARED |
A boundary value for comparing if two points are similar.
| |
HASH_SEED |
A default seed value for creating hash codes.
| |
X |
The X-coordinate of the point.
| |
Y |
The Y-coordinate of the point.
| |
Z |
The Z-coordinate of the point.
|
See Also