PluginWindowBase Class |
The PluginWindowBase class is the base class for plug-in WPF dialogs. The class extends
the WindowBase class by adding communications with Tekla Structures.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.WindowsWindow
Tekla.Structures.DialogWindowBase
Tekla.Structures.DialogPluginWindowBase
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.WindowsWindow
Tekla.Structures.DialogWindowBase
Tekla.Structures.DialogPluginWindowBase
Namespace: Tekla.Structures.Dialog
Assembly: Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.3
Syntax
The PluginWindowBase type exposes the following members.
Constructors
Name | Description | |
---|---|---|
PluginWindowBase |
Runs the WindowBase constructor and loads the default .NET localization file (DotNetDialogStrings.ail).
Datastorage is built based on given viewmodel object
|
Properties
Name | Description | |
---|---|---|
Localization |
The localization instance for the dialog. Each dialog has its own localization instance
that has read the localization files needed for that dialog.
(Inherited from WindowBase.) | |
LocExtension |
The localization instance for the dialog. Each dialog has its own localization instance
that has read the localization files needed for that dialog.
(Inherited from WindowBase.) | |
ShowInTaskbar |
Hides (shadows) the ShowInTaskbar property by setting the property to false.
| |
UseDefaultStyle |
Use default style in all the window controls or not.
If the property is not set in the window constructor the default value (true) is used.
(Inherited from WindowBase.) |
Methods
Name | Description | |
---|---|---|
ApplyValues |
Loads the dialog values from a file and performs Apply on the loaded values.
To match the files to a certain dialog, the file suffix is set as the dialog type's name.
(Inherited from WindowBase.) | |
Get |
Gets the dialog values from the part that is currently selected in Tekla Structures.
| |
GetConnectionStatus |
Returns true if a proper connection to the Tekla Structures process has been established.
Currently, there's no way to re-establish the connection.
(Inherited from WindowBase.) | |
InitializeWindow |
Prepares the data storage for the dialog and scans through the fields.
(Inherited from WindowBase.) | |
LoadValues |
Loads the dialog values from a file. To match the files to a certain dialog,
the file suffix is set as the dialog type's name.
(Inherited from WindowBase.) | |
ModifyValues |
Loads the dialog values from a file and performs Modify on the loaded values.
To match the files to a certain dialog, the file suffix is set as the dialog type's name.
(Inherited from WindowBase.) | |
ReloadWindow |
Reloads the dialog values.
| |
SaveValues |
Serializes the dialog values to an xml file.
(Inherited from WindowBase.) | |
ShowWindow |
Displays the window.
(Inherited from WindowBase.) | |
UpdateDataStorageFromViewModel |
DO NOT USE! For internal usage only!
(Inherited from WindowBase.) |
Events
Name | Description | |
---|---|---|
AttributesLoadedFromModel |
The AttributesLoadedFromModel event is triggered just after the attributes have been loaded
from the model into the dialog.
|
See Also