PluginUserInterfaceAttribute Class |
The PluginUserInterfaceAttribute class is used for storing the description of the plug-in user interface to the system.
The attribute is initialized from the custom attribute [PluginUserInterface(PluginName.UserInterfaceDefinitions.Plugin1)] in the plug-in source.
In this case the description string Plugin1 is a dialog written in inp format.
If the plug-in dialog is inherited from the PluginFormBase the description string contains a class name of the dialog i.e. [PluginUserInterface("Model_Plug_in1.MainForm")].
Inheritance Hierarchy
Namespace: Tekla.Structures.Plugins
Assembly: Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2023.0.3
Syntax
The PluginUserInterfaceAttribute type exposes the following members.
Constructors
Name | Description | |
---|---|---|
PluginUserInterfaceAttribute |
The custom attribute [PluginUserInterface(PluginName.UserInterfaceDefinitions.Plugin1)] uses this to store the description of the plug-in user interface to the system.
This is not to be used by itself.
|
Properties
Name | Description | |
---|---|---|
Description |
The description of the plug-in user interface in inp format.
|
See Also