PluginBaseInputDefinition Class |
The InputDefinition class is a class for defining the plug-in dependency over the input (points or identifiers).
The user implemented method DefineInput() of the PluginBase interface should return an array list of
input definition instances. This defines the points and identifiers the plug-in will receive as input
when the Run() method is called.
Inheritance Hierarchy
Namespace: Tekla.Structures.Plugins
Assembly: Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2023.0.3
Syntax
The PluginBaseInputDefinition type exposes the following members.
Constructors
Name | Description | |
---|---|---|
PluginBaseInputDefinition(ArrayList) |
Creates a new input definition instance with multiple point or identifier instances.
| |
PluginBaseInputDefinition(Identifier) |
Creates a new input definition instance with one identifier.
| |
PluginBaseInputDefinition(Point) |
Creates a new input definition instance with one point.
| |
PluginBaseInputDefinition(Point, Point) |
Creates a new input definition instance with two points.
|
Methods
Name | Description | |
---|---|---|
GetInput |
Returns the input Tekla Structures gave to the plug-in. The input is either a point instance,
an identifier instance, an array list of points or an array list of identifiers. This is based on the input
format returned from the DefineInput() method.
| |
GetInputType |
Returns the type of the input the current instance contains.
|
See Also