ParallelPlaneToPlane Method (GeometricPlane, GeometricPlane, Double)

Returns true if the given planes are parallel within the given angular tolerance.

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
public static bool PlaneToPlane(
	GeometricPlane Plane1,
	GeometricPlane Plane2,
	double Tolerance
)

Parameters

Plane1
Type: Tekla.Structures.Geometry3dGeometricPlane
The first plane to be used.
Plane2
Type: Tekla.Structures.Geometry3dGeometricPlane
The second plane to be used.
Tolerance
Type: SystemDouble
The angular tolerance (in radians) to be used.

Return Value

Type: Boolean
True if the given planes are parallel within the given tolerance.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next