Plane Class

The Plane class defines a plane in space using an origin, an X-axis and a Y-axis.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.ModelPlane

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class Plane

The Plane type exposes the following members.

Constructors
  NameDescription
Public methodPlane
Initializes a new plane instance.
Top
Properties
  NameDescription
Public propertyAxisX
The X-axis of the plane.
Public propertyAxisY
The Y-axis of the plane.
Public propertyOrigin
The origin of the plane.
Top
Examples
using Tekla.Structures.Model;
using Tekla.Structures.Geometry3d;

public class Example
{
       public void Example1()
       {
           Plane Plane = new Plane();
           Plane.Origin = new Point(500, 0, 0);
           Plane.AxisX = new Vector(500, 1000, 0);
           Plane.AxisY = new Vector(500, 0, -1000);
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next