Plane Class |
The Plane class defines a plane in space using an origin, an X-axis and a Y-axis.
Inheritance Hierarchy
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
The Plane type exposes the following members.
Constructors
Properties
Name | Description | |
---|---|---|
AxisX |
The X-axis of the plane.
| |
AxisY |
The Y-axis of the plane.
| |
Origin |
The origin of the plane.
|
Examples
using Tekla.Structures.Model; using Tekla.Structures.Geometry3d; public class Example { public void Example1() { Plane Plane = new Plane(); Plane.Origin = new Point(500, 0, 0); Plane.AxisX = new Vector(500, 1000, 0); Plane.AxisY = new Vector(500, 0, -1000); } }
See Also