PlacingTypes Class |
The PlacingTypes class defines the different available placing types.
Please note that not all objects accept all types.
If you try to use the wrong type it will not be accepted (Insert, Modify will fail).
Inheritance Hierarchy
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
The PlacingTypes type exposes the following members.
Methods
Name | Description | |
---|---|---|
AlongLinePlacing |
The object is located and moved along a line defined by two points.
| |
BaseLinePlacing |
The object is placed using a line as a reference.
This will thus define the object's X-axis along that line.
| |
LeaderLinePlacing |
The object is placed attached to a leader line.
| |
PointPlacing |
The object is placed at one point (the insertion point) without any additional placing options.
|
See Also