PlacingQuarterAttributes Class |
The PlacingQuarterAttributes class contains the basic attributes for placing quarters.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingGenericAttributesBase
Tekla.Structures.DrawingPlacingQuarterAttributes
Tekla.Structures.DrawingGenericAttributesBase
Tekla.Structures.DrawingPlacingQuarterAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
The PlacingQuarterAttributes type exposes the following members.
Constructors
Name | Description | |
---|---|---|
PlacingQuarterAttributes |
Creates a new placing quarter attributes instance. The default parameters are:
TopLeft = true, TopRight = true, BottomLeft = true, BottomRight = true.
| |
PlacingQuarterAttributes(Boolean, Boolean, Boolean, Boolean) |
Creates a new placing quarter attributes instance with the given parameters.
|
Properties
Name | Description | |
---|---|---|
BottomLeft |
Defines whether the object can search for a suitable location in the bottom left direction.
| |
BottomRight |
Defines whether the object can search for a suitable location in the bottom right direction.
| |
TopLeft |
Defines whether the object can search for a suitable location in the top left direction.
| |
TopRight |
Defines whether the object can search for a suitable location in the top right direction.
|
Methods
Name | Description | |
---|---|---|
Clone |
Creates a new object that is a copy of the current instance.
| |
IsEqual |
Compares the current object with an object of the same type.
(Overrides GenericAttributesBaseIsEqual(Object).) |
See Also