PlacingDistanceAttributes Class |
The PlacingDistanceAttributes class contains the basic attributes for placing distances.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingGenericAttributesBase
Tekla.Structures.DrawingPlacingDistanceAttributes
Tekla.Structures.DrawingGenericAttributesBase
Tekla.Structures.DrawingPlacingDistanceAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
The PlacingDistanceAttributes type exposes the following members.
Constructors
Name | Description | |
---|---|---|
PlacingDistanceAttributes |
Initializes a new instance of the PlacingDistanceAttributes class.
The default values are a 0.0 search margin and a 0.0 minimal distance.
| |
PlacingDistanceAttributes(Double, Double) |
Creates a new placing distance attributes instance with the given search marginal and minimal distance.
| |
PlacingDistanceAttributes(Double, Double, Double) |
Creates a new placing distance attributes instance with the given search margin, minimal and maximal distance.
|
Properties
Name | Description | |
---|---|---|
MaximalDistance |
Gets or sets the maximal distance for placing.
| |
MinimalDistance |
Gets or sets the minimal distance for placing.
| |
SearchMargin |
Gets or sets the search marginal for placing.
|
Methods
Name | Description | |
---|---|---|
Clone |
Creates a new object that is a copy of the current instance.
| |
IsEqual |
Compares the current object with an object of the same type.
(Overrides GenericAttributesBaseIsEqual(Object).) |
See Also