![]() | PlacingDirectionAttributes Class |
The PlacingDirectionAttributes class contains the basic attributes for placing directions.

SystemObject
Tekla.Structures.DrawingGenericAttributesBase
Tekla.Structures.DrawingPlacingDirectionAttributes
Tekla.Structures.DrawingGenericAttributesBase
Tekla.Structures.DrawingPlacingDirectionAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3

The PlacingDirectionAttributes type exposes the following members.

Name | Description | |
---|---|---|
![]() | PlacingDirectionAttributes |
Creates a new placing direction attributes instance. The positive and negative
directions are set to false by default.
|
![]() | PlacingDirectionAttributes(Boolean, Boolean) |
Creates a new placing direction attributes instance.
|

Name | Description | |
---|---|---|
![]() | Negative |
The negative direction of placing.
|
![]() | Positive |
The positive direction of placing.
|

Name | Description | |
---|---|---|
![]() | IsEqual |
Compares the current object with an object of the same type.
(Overrides GenericAttributesBaseIsEqual(Object).) |