PickerPickPoint Method (String, Point, ViewBase)

Requests the user to pick one point.

Namespace:  Tekla.Structures.Drawing.UI
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
public void PickPoint(
	string prompt,
	out Point pickedPoint,
	out ViewBase pickedView
)

Parameters

prompt
Type: SystemString
The prompt shown in the status bar. See the class remarks for more information about prompts.
pickedPoint
Type: Tekla.Structures.Geometry3dPoint
The picked point in the view coordinates.
pickedView
Type: Tekla.Structures.DrawingViewBase
The view in which the pick occurred.
Exceptions
ExceptionCondition
InvalidPluginPickerInputException Thrown when the picker is being used through a plug-in which has invalid PluginPickerInputs defined.
PickerInterruptedException Thrown when the user interrupts the picker before anything has been picked.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next