PickerPickObjects Method (PickerPickObjectsEnum, String)

Queries the user to pick model objects from the model with the given prompt.

Namespace:  Tekla.Structures.Model.UI
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
public ModelObjectEnumerator PickObjects(
	PickerPickObjectsEnum Enum,
	string Prompt
)

Parameters

Enum
Type: Tekla.Structures.Model.UIPickerPickObjectsEnum
Indicates the type and amount of objects to pick.
Prompt
Type: SystemString
The string to display as user guidance.

Return Value

Type: ModelObjectEnumerator
An enumerator of model object instances.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next