PartPartAttributes Class |
The PartAttributes class is the attributes class for the part.
Inheritance Hierarchy
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
The PartPartAttributes type exposes the following members.
Constructors
Name | Description | |
---|---|---|
PartPartAttributes |
Creates a new default part attributes instance that loads standard attributes.
| |
PartPartAttributes(String) |
Creates a new part attributes instance that loads the specified attributes.
|
Properties
Name | Description | |
---|---|---|
CustomPresentation |
Custom presentation GUID to be applied to the object type
| |
DrawCenterLine |
True if the center line is drawn.
| |
DrawChamfers |
True if chamfers are drawn.
| |
DrawConnectingSideMarks |
True if connecting side marks are drawn.
| |
DrawHiddenLines |
True if hidden lines are drawn.
| |
DrawOrientationMark |
True if the orientation mark is drawn.
| |
DrawOwnHiddenLines |
True if own hidden lines are drawn.
| |
DrawPopMarks |
True if pop marks are drawn.
| |
DrawReferenceLine |
True if the reference line is drawn.
| |
FaceHatch |
The hatch type of the face hatch.
| |
HiddenLines |
The line type of hidden lines.
| |
PartialProfileLength |
Gets or sets the partial profile length.
| |
PartialProfileOffset |
Gets or sets the partial profile offset.
| |
ReferenceLine |
The line type of the reference line.
| |
Representation |
The representation of the part.
| |
SectionFaceHatch |
The hatch type of the section face hatch.
| |
SymbolOffset |
The symbol offset.
| |
VisibleLines |
The line type of visible lines.
|
Methods
Name | Description | |
---|---|---|
IsEqual |
Compares the current object with an object of the same type.
(Overrides AttributesBaseIsEqual(Object).) | |
LoadAttributes |
Loads the attributes from the attribute file.
(Overrides AttributesBaseLoadAttributes(String).) |
See Also