Part Constructor

Initializes a new instance of the Part class with default attributes.

The default values are set as follows:

  • Position = new Position();
  • Profile = new Profile();
  • Material = new Material();
  • DeformingData = new DeformingData();
  • Name = "";
  • Class = "";
  • Finish = "";
  • PartNumber = new NumberingSeries("P", 1);
  • AssemblyNumber = new NumberingSeries("A", 1);
  • CastUnitType = CastUnitTypeEnum.PRECAST;

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
public Part()
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next