ParametricObject_CustomProfile Class

The ParametricObject_CustomProfile class contains the custom profile definition.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.Model.CollaborationReferenceModelObjectAttribute
    Tekla.Structures.Model.CollaborationParametricObject_CustomProfile

Namespace:  Tekla.Structures.Model.Collaboration
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class ParametricObject_CustomProfile : ReferenceModelObjectAttribute

The ParametricObject_CustomProfile type exposes the following members.

Properties
  NameDescription
Public propertyDescription
The description of the product.
(Inherited from ReferenceModelObjectAttribute.)
Public propertyExtrusion
The extrusion vector.
(Inherited from ReferenceModelObjectAttribute.)
Public propertyName
The name of the product.
(Inherited from ReferenceModelObjectAttribute.)
Public propertyObjectType
The object type of the product.
(Inherited from ReferenceModelObjectAttribute.)
Public propertyOrigin
The origin of the extrusion.
(Inherited from ReferenceModelObjectAttribute.)
Public propertyProfileName
The name of the profile (often empty).
(Inherited from ReferenceModelObjectAttribute.)
Public propertyxDir
The X-axis direction.
(Inherited from ReferenceModelObjectAttribute.)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next