Parallel Class |
The Parallel class contains methods for testing the parallelism of geometric objects.
Inheritance Hierarchy
Namespace: Tekla.Structures.Geometry3d
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
Methods
Name | Description | |
---|---|---|
LineSegmentToLineSegment(LineSegment, LineSegment) |
Returns true if the given line segments are parallel.
| |
LineSegmentToLineSegment(LineSegment, LineSegment, Double) |
Returns true if the given line segments are parallel within the given angular tolerance.
| |
LineSegmentToPlane(LineSegment, GeometricPlane) |
Returns true if the given line segment and plane are parallel.
| |
LineSegmentToPlane(LineSegment, GeometricPlane, Double) |
Returns true if the given line segment and plane are parallel within the given angular tolerance.
| |
LineToLine(Line, Line) |
Returns true if the given lines are parallel.
| |
LineToLine(Line, Line, Double) |
Returns true if the given lines are parallel within the given angular tolerance.
| |
LineToPlane(Line, GeometricPlane) |
Returns true if the given line and plane are parallel.
| |
LineToPlane(Line, GeometricPlane, Double) |
Returns true if the given line and plane are parallel within the given angular tolerance.
| |
PlaneToPlane(GeometricPlane, GeometricPlane) |
Returns true if the given planes are parallel.
| |
PlaneToPlane(GeometricPlane, GeometricPlane, Double) |
Returns true if the given planes are parallel within the given angular tolerance.
| |
VectorToPlane(Vector, GeometricPlane) |
Returns true if the given vector and plane are parallel.
| |
VectorToPlane(Vector, GeometricPlane, Double) |
Returns true if the given vector and plane are parallel within the given angular tolerance.
| |
VectorToVector(Vector, Vector) |
Returns true if the given vectors are parallel.
| |
VectorToVector(Vector, Vector, Double) |
Returns true if the given vectors are parallel within the given angular tolerance.
|
See Also