Operation Class |
Operations of analysis objects.
Inheritance Hierarchy
Namespace: Tekla.Structures.Analysis.Operations
Assembly: Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.3
Syntax
The Operation type exposes the following members.
Constructors
Methods
Name | Description | |
---|---|---|
MoveAnalysisPartAreaEdge |
Moves the analysis part area edge by translation vector.
Perpendicular offset is calculated from the translation vector.
| |
MoveAnalysisPartPosition |
Moves the analysis part position by translation vector.
Only the handle positions can be moved.
| |
MoveObject |
Moves the analysis object by translation vector.
Supported objects are: AnalysisNode, AnalysisPart.
| |
ResetAnalysisPartPositions |
Reset analysis part. Removes the offsets applied to node positions.
The axis offset of the analysis part is not reset.
|
See Also