OpenGraphicObject Class |
The OpenGraphicObject class is an abstract base class for all open graphic objects
(the arc, the line and the polyline).
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawingObject
Tekla.Structures.DrawingGraphicObject
Tekla.Structures.DrawingOpenGraphicObject
Tekla.Structures.DrawingArc
Tekla.Structures.DrawingLine
Tekla.Structures.DrawingPolyline
Tekla.Structures.DrawingDatabaseObject
Tekla.Structures.DrawingDrawingObject
Tekla.Structures.DrawingGraphicObject
Tekla.Structures.DrawingOpenGraphicObject
Tekla.Structures.DrawingArc
Tekla.Structures.DrawingLine
Tekla.Structures.DrawingPolyline
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
The OpenGraphicObject type exposes the following members.
Properties
Name | Description | |
---|---|---|
Methods
Name | Description | |
---|---|---|
GetUserProperty(String, Double) |
Gets a double property from the drawing object. The object has to be in a drawing before
GetUserProperty(String, Int32) |
Gets an integer property from the drawing object. The object has to be in a drawing before
GetUserProperty(String, String) |
Gets a string property from the drawing object. The object has to be in a drawing before
IsEqual |
Compares the current object with the given object.
SetUserProperty(String, Double) |
Sets a double property for the drawing object. The object has to be in a drawing before
SetUserProperty(String, Int32) |
Sets an integer property for the drawing object. The object has to be in a drawing before
SetUserProperty(String, String) |
Sets a string property for the drawing object. The object has to be in a drawing before
See Also