OkApplyModifyGetOnOffCancel Class |
The OkApplyModifyGetOnOffCancel class represents a control including the Ok-Apply-Modify-Get-On/Off-Cancel button group.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Tekla.Structures.Dialog.UIControlsOkApplyModifyGetOnOffCancel
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsUserControl
Tekla.Structures.Dialog.UIControlsOkApplyModifyGetOnOffCancel
Namespace: Tekla.Structures.Dialog.UIControls
Assembly: Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.3
Syntax
The OkApplyModifyGetOnOffCancel type exposes the following members.
Constructors
Name | Description | |
---|---|---|
OkApplyModifyGetOnOffCancel |
Initializes a new instance of the OkApplyModifyGetOnOffCancel class.
|
Events
Name | Description | |
---|---|---|
ApplyClicked |
The ApplyClicked event is raised when the Apply button is clicked.
| |
CancelClicked |
The CancelClicked event is raised when the Cancel button is clicked.
| |
GetClicked |
The GetClicked event is raised when the Get button is clicked.
| |
ModifyClicked |
The ModifyClicked event is raised when the Modify button is clicked.
| |
OkClicked |
The OkClicked event is raised when the Ok button is clicked.
| |
OnOffClicked |
The OnOffClicked event is raised when the On-Off button is clicked.
|
See Also