OperationObjectMatchesToFilter Method (ModelObject, String)

Checks whether the object matches to the criteria in the given filter.

Namespace:  Tekla.Structures.Model.Operations
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
public static bool ObjectMatchesToFilter(
	ModelObject ModelObject,
	string FilterName
)

Parameters

ModelObject
Type: Tekla.Structures.ModelModelObject
The model object to check.
FilterName
Type: SystemString
The filter file to check against.

Return Value

Type: Boolean
True if the object matches to the given filter criteria.
Exceptions
ExceptionCondition
ArgumentExceptionThrown when the ModelObject is not valid.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next