IMovableRelativeMoveObjectRelative Method

Moves the current object using the move vector. The move vector can be calculated as in the following example.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
bool MoveObjectRelative(
	Vector MoveVector
)

Parameters

MoveVector
Type: Tekla.Structures.Geometry3dVector
The move vector to be used for moving the object.

Return Value

Type: Boolean
True on success.
Examples
The example calculates a move vector from two points. The move vector in the example will move an object 1000 points in the +X direction.
using Tekla.Structures.Geometry3d;

public class Example
{
       public void Example1()
       {
           Tekla.Structures.Geometry3d.Vector MoveVec =
               new Tekla.Structures.Geometry3d.Vector(new Point(1000, 0) - new Point(0, 0));
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next