OperationMoveObject Method

Moves the analysis object by translation vector. Supported objects are: AnalysisNode, AnalysisPart.

Namespace:  Tekla.Structures.Analysis.Operations
Assembly:  Tekla.Structures.Analysis (in Tekla.Structures.Analysis.dll) Version: 2023.0.3
Syntax
public static bool MoveObject(
	AnalysisObject analysisObject,
	Vector translation
)

Parameters

analysisObject
Type: Tekla.Structures.AnalysisAnalysisObject
The analysis object to move.
translation
Type: Tekla.Structures.Geometry3dVector
The vector for moving the object.

Return Value

Type: Boolean
True on success, false on failure.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next