ModuleManager Class |
The ModuleManager class handles the product model module configuration information: the
information that defines what configuration the customer is currently running.
Inheritance Hierarchy
Namespace: Tekla.Structures
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
The ModuleManager type exposes the following members.
Constructors
Name | Description | |
---|---|---|
ModuleManager | Initializes a new instance of the ModuleManager class |
Properties
Name | Description | |
---|---|---|
AnalysisAndDesign | Indicates whether the Analysis and Design management is enabled. | |
CIPModeling | Indicates whether the CIP modeling is enabled. | |
ConcreteDetailing | Indicates whether the concrete detailing is enabled. | |
Configuration | The currently running configuration of Tekla Structures. | |
LoadModeling | Indicates whether the load modeling is enabled. | |
MultimaterialModeling | Indicates whether the multimaterial modeling is enabled. | |
RebarModeling | Indicates whether the rebar modeling is enabled. | |
SteelDetailing | Indicates whether the steel detailing is enabled. | |
TaskManagement | Indicates whether the task management is enabled. |
See Also