BentPlateGeometrySolverModifyPolygon Method |
Modify the shape of a polygon section, and updates related cylindrical sections accordingly.
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
public ConnectiveGeometry ModifyPolygon( ConnectiveGeometry geometry, GeometrySection polygonSection, Contour points )
Parameters
- geometry
- Type: Tekla.Structures.ModelConnectiveGeometry
Reference geometry to modify which contains polygonSection. - polygonSection
- Type: Tekla.Structures.ModelGeometrySection
A polygon section from geometry to modify. - points
- Type: Tekla.Structures.ModelContour
The modified contour for the section.
Return Value
Type: ConnectiveGeometryModified ConnectiveGeometry if command succeeded or geometry otherwise.
Exceptions
Exception | Condition |
---|---|
ConnectiveGeometryException | Thrown if could not modify polygon. |
See Also