ModificationStamp Class |
The ModificationStamp class provides the modification stamp for the objects of the model
that is currently open in Tekla Structures.
Inheritance Hierarchy
Namespace: Tekla.Structures.Model.History
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
The ModificationStamp type exposes the following members.
Constructors
Name | Description | |
---|---|---|
ModificationStamp |
Creates a new modification stamp instance where the current modification stamp is 0.
Can be used for fetching all the created or deleted model objects from the model history.
| |
ModificationStamp(Int32, Int32) |
Creates a new modification stamp instance with the given local and server stamps.
Can be used for fetching from the model history all the model objects that have been created
or deleted after the specified stamp.
|
Properties
Name | Description | |
---|---|---|
Guid | Guid representation | |
LocalStamp |
The modification stamp for the local changes.
| |
ServerStamp |
The modification stamp from the multi-user server for the external changes caused by
the saving of the multi-user model.
|
See Also