ModelObjectHatchAttributes Class |
The ModelObjectHatchAttributes class contains hatch attributes for model object hatches.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingGenericAttributesBase
Tekla.Structures.DrawingHatchAttributes
Tekla.Structures.DrawingModelObjectHatchAttributes
Tekla.Structures.DrawingGenericAttributesBase
Tekla.Structures.DrawingHatchAttributes
Tekla.Structures.DrawingModelObjectHatchAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
The ModelObjectHatchAttributes type exposes the following members.
Properties
Name | Description | |
---|---|---|
DrawBackgroundColor |
Sets whether the background color will be enabled or disabled for the hatch.
Name |
The name of the hatch.
Methods
Name | Description | |
---|---|---|
IsEqual |
Compares the current object with an object of the same type.
(Overrides GenericAttributesBaseIsEqual(Object).) |
See Also