ModelAccess Class |
The ModelAccess class contains helper methods for connecting to and accessing the model and objects in the model.
The class attempts to provide efficient but robust methods for connecting to and verifying the connection to the model.
Inheritance Hierarchy
Namespace: Tekla.Structures.Dialog.UIControls
Assembly: Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.3
Syntax
The ModelAccess type exposes the following members.
Constructors
Name | Description | |
---|---|---|
ModelAccess | Initializes a new instance of the ModelAccess class |
Methods
Name | Description | |
---|---|---|
ConnectToModel |
Gets a model connnection.
| |
ConnectToModel(Boolean) |
Gets a model connection.
| |
ConnectToModel(Model) |
Gets a model connection.
|
See Also