DistanceMillimeters Property |
Gets or sets the distance in millimeters.
Namespace: Tekla.Structures.Datatype
Assembly: Tekla.Structures.Datatype (in Tekla.Structures.Datatype.dll) Version: 2023.0.3
Syntax
Examples
This example shows how to perform calculations with distances in different units.
using Tekla.Structures.Datatype; public class Example { public void Example1() { // The default unit type is millimeter. Distance value1 = new Distance(30); // Other unit types must be specified explicitly. Distance value2 = new Distance(2, Distance.UnitType.Inch); // Perform sum calculation using millimeters for both distances. Distance sumOfDistances = new Distance(value1.Millimeters + value2.Millimeters); } }
See Also