MeshItem Class

The MeshItem class contains information from the meshes in the catalog (mesh_database.inp).
Inheritance Hierarchy
SystemObject
  Tekla.Structures.CatalogsMeshItem

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class MeshItem

The MeshItem type exposes the following members.

Constructors
  NameDescription
Public methodMeshItem
Creates a new mesh item instance.
Top
Properties
  NameDescription
Public propertyDiameterCross
The mesh item's cross direction bar size.
Public propertyDiameterLongitudinal
The mesh item's longitudinal direction bar size.
Public propertyDistanceCross
The mesh item's cross direction distance.
Public propertyDistanceLongitudinal
The mesh item's longitudinal direction distance.
Public propertyGrade
The mesh item's grade.
Public propertyLeftOverhangCross
The mesh item's cross direction left overhang.
Public propertyLeftOverhangLongitudinal
The mesh item's longitudinal direction left overhang.
Public propertyLength
The mesh item's length.
Public propertyMaximumOverlappingCross
The mesh item's cross direction maximum overlapping.
Public propertyMaximumOverlappingLongitudinal
The mesh item's longitudinal direction maximum overlapping.
Public propertyMinimumOverlappingCross
The mesh item's cross direction minimum overlapping.
Public propertyMinimumOverlappingLongitudinal
The mesh item's longitudinal direction minimum overlapping.
Public propertyName
The mesh item's name.
Public propertyRightOverhangCross
The mesh item's cross direction right overhang.
Public propertyRightOverhangLongitudinal
The mesh item's longitudinal direction right overhang.
Public propertyWidth
The mesh item's width.
Top
Methods
  NameDescription
Public methodCode exampleExport
Exports the rebar item in the catlog to given file name. If path is not given rebar is exported to model folder. If filename is empty rebar name is used as filename.
Public methodSelect
Selects the mesh item in the mesh database.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next