Matrix Class |
The Matrix class represents a 4x3 matrix.
Inheritance Hierarchy
Namespace: Tekla.Structures.Geometry3d
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
The Matrix type exposes the following members.
Constructors
Name | Description | |
---|---|---|
Matrix |
Creates a new indentity matrix.
| |
Matrix(Matrix) |
Creates a new matrix which is a copy of the given matrix.
|
Properties
Methods
Name | Description | |
---|---|---|
GetTranspose |
Returns a new matrix which is a transpose of the current matrix.
The transposed matrix is an inversion of the current matrix,
if the current matrix was a valid rotation matrix.
| |
ToString |
Returns a string that represents the current matrix.
(Overrides ObjectToString.) | |
Transform(IEnumerablePoint) |
Transforms the given points using the current matrix.
| |
Transform(Point) |
Transforms the given point using the current matrix.
| |
Transpose |
Transposes a matrix. The resulting matrix is an inversion of the current matrix,
if the current matrix was a valid rotation matrix.
|
Operators
Name | Description | |
---|---|---|
Multiply(Matrix, IEnumerablePoint) |
Transforms the given points using the given matrix.
| |
Multiply(Matrix, Matrix) |
Multiplies (combines) two transformation matrices.
| |
Multiply(Matrix, Point) |
Transforms the given point using the given matrix.
|
See Also