MaterialSelectionForm Class |
The MaterialSelectionForm class represents a dialog to select materials
using the material catalogs.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Tekla.Structures.Dialog.UIControlsMaterialSelectionForm
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
Tekla.Structures.Dialog.UIControlsMaterialSelectionForm
Namespace: Tekla.Structures.Dialog.UIControls
Assembly: Tekla.Structures.Dialog (in Tekla.Structures.Dialog.dll) Version: 2023.0.3
Syntax
The MaterialSelectionForm type exposes the following members.
Constructors
Name | Description | |
---|---|---|
MaterialSelectionForm(ListMaterialItem) |
Creates a new instance of the MaterialSelectionForm.
| |
MaterialSelectionForm(ListMaterialItem, String) |
Creates a new instance of the MaterialSelectionForm, selecting the given material in the tree control.
|
Properties
Name | Description | |
---|---|---|
SelectedMaterial |
The selected material in the control.
|
See Also