MateriaClientAdapter Class |
Adapter class used for Materia-TS integration.
Inheritance Hierarchy
Namespace: Tekla.Structures.TeklaStructuresInternal.MateriaClient
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
The MateriaClientAdapter type exposes the following members.
Properties
Name | Description | |
---|---|---|
Instance |
Get the IMateriaClientAdapter instance
|
Methods
Name | Description | |
---|---|---|
Connect |
Tries to connect to the Materia server.
Note: this method must be called from the UI thread
| |
Disconnect |
Disconnect from Materia server
| |
Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. | |
IsConnectionActive |
Returns the value whether connection to Materia server is active or not.
| |
LoadGraph(Asset) |
Loads the graph corresponding to the specified uri and retrieves it's GUID
| |
LoadGraph(Asset, ListGraphParameter) |
Loads the graph corresponding to the specified uri providing the explicit parameter values and retrieves it's GUID
| |
SearchAssets |
Searches for materia assets by name and retrieves a list of asset names and guids.
|
Events
Name | Description | |
---|---|---|
ConnectionChanged |
Event for notifying about connection changes
|
See Also