MarkBaseMarkBaseAttributes Class |
The MarkBaseAttributes class is the attributes class for the mark base.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingMarkBaseMarkBaseAttributes
Tekla.Structures.DrawingMarkMarkAttributes
Tekla.Structures.DrawingMarkSetMarkSetAttributes
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingMarkBaseMarkBaseAttributes
Tekla.Structures.DrawingMarkMarkAttributes
Tekla.Structures.DrawingMarkSetMarkSetAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
The MarkBaseMarkBaseAttributes type exposes the following members.
Constructors
Name | Description | |
---|---|---|
MarkBaseMarkBaseAttributes |
Creates a new default mark base attributes instance that loads standard attributes.
| |
MarkBaseMarkBaseAttributes(String) |
Creates a new mark base attributes instance with the given attributes file's filename.
|
Properties
Name | Description | |
---|---|---|
Angle |
The actual angle of the mark, in degrees. Can differ from the rotation angle
set by the user for marks, e.g. 45-degree column marks in GA drawings or
when placing mark along part edges.
| |
ArrowHead |
The arrowhead of the leader line(s).
| |
CustomPresentation |
Custom presentation GUID to be applied to the object type
| |
Frame |
The frame attributes of the mark's labels.
| |
PlacingAttributes |
The placing attributes that the object should use.
Using these you can specify whether the object is automatically arranged in the drawing or not.
| |
PreferredPlacing |
The type of placing the object should use.
See the preferred placing types for different types of placing.
| |
RotationAngle |
The mark rotation angle set by the user. Unit is degrees.
| |
TextAlignment |
The mark text alignment.
| |
TransparentBackground |
The mark text background transparency. (transparent/opaque)
|
Methods
Name | Description | |
---|---|---|
IsEqual |
Compares the current object with an object of the same type.
(Inherited from AttributesBase.) | |
LoadAttributes |
Loads the attributes from the specified file.
(Inherited from AttributesBase.) |
See Also