LoadTemperature Class |
The LoadTemperature class defines a temperature change in a part, or a temperature difference between two part surfaces.
Inheritance Hierarchy
SystemObject
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelLoad
Tekla.Structures.ModelLoadTemperature
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelLoad
Tekla.Structures.ModelLoadTemperature
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
The LoadTemperature type exposes the following members.
Constructors
Name | Description | |
---|---|---|
LoadTemperature |
Initializes a new instance of the LoadTemperature class.
|
Properties
Name | Description | |
---|---|---|
AutomaticPrimaryAxisWeight | Obsolete.
Property not supported in LoadTemperature class.
| |
BoundingBoxDx |
The dimension of the bounding box in the X direction.
(Inherited from Load.) | |
BoundingBoxDy |
The dimension of the bounding box in the Y direction.
(Inherited from Load.) | |
BoundingBoxDz |
The dimension of the bounding box in the Z direction.
(Inherited from Load.) | |
CreateFixedSupportConditionsAutomatically | Obsolete.
Property not supported in LoadTemperature class.
| |
FatherId |
The identifier of the father object that the load is attached to.
(Inherited from Load.) | |
Group |
The load group object for the load.
(Inherited from Load.) | |
Identifier |
The identifier of the object.
(Inherited from Object.) | |
InitialAxialElongation |
Gets or sets the initial axial elongation.
| |
IsUpToDate | Gets if the object does not have a modification which is not shared. (Inherited from ModelObject.) | |
LoadAttachment |
The load attachment.
(Inherited from Load.) | |
LoadDispersionAngle | Obsolete.
Property not supported in LoadTemperature class.
| |
ModificationTime | Gets latest time of the object was modified or created. (Inherited from ModelObject.) | |
PartFilter |
The part filter.
(Inherited from Load.) | |
PartNames |
The part names.
(Inherited from Load.) | |
Position1 |
Gets or sets the first input position point.
| |
Position2 |
Gets or sets the second input position point.
| |
PrimaryAxisDirection | Obsolete.
Property not supported in LoadTemperature class.
| |
Spanning | Obsolete.
Property not supported in LoadTemperature class.
| |
TemperatureChangeForAxialElongation |
Gets or sets the temperature change for axial elongation.
| |
TemperatureDifferentialSideToSide |
Gets or sets the temperature differential from side to side.
| |
TemperatureDifferentialTopToBottom |
Gets or sets the temperature differential from top to bottom.
| |
Weight | Obsolete.
Property not supported in LoadTemperature class.
|
Methods
Name | Description | |
---|---|---|
CompareTo |
Compares Identifiers of model objects.
(Inherited from ModelObject.) | |
Delete |
Deletes the load temperature instance with the given ID from the model database.
(Overrides ModelObjectDelete.) | |
Equals |
Check if Identifiers of model objects are same.
(Inherited from ModelObject.) | |
GetAllReportProperties |
Retrieves all properties for the model object in one hashtable.
Type for the returned value must be checked using type casting.
(Inherited from ModelObject.) | |
GetAllUserProperties |
Retrieves all properties for the model object in one hashtable.
Type for the returned value must be checked using type casting.
(Inherited from ModelObject.) | |
GetChildren |
Returns an enumerator of all the children model objects.
(Inherited from ModelObject.) | |
GetCoordinateSystem |
Returns the coordinate system for the given model object.
(Inherited from ModelObject.) | |
GetDoubleReportProperties |
Retrieves multiple double report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) | |
GetDoubleUserProperties |
Retrieves all double properties for the model object.
(Inherited from ModelObject.) | |
GetDynamicStringProperty |
Gets a dynamic string property from the model object.
(Inherited from ModelObject.) | |
GetFatherComponent |
Returns the father component of the model object.
(Inherited from ModelObject.) | |
GetHierarchicObjects |
Returns an enumerator of all the connected hierarchic objects.
(Inherited from ModelObject.) | |
GetIntegerReportProperties |
Retrieves multiple integer report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) | |
GetIntegerUserProperties |
Retrieves all integer properties for the model object.
(Inherited from ModelObject.) | |
GetPhase |
Retrieves the phase of the model object (the phase number, the phase name,
the phase comment and whether the phase is the current one or not).
(Inherited from ModelObject.) | |
GetReportProperty(String, Double) |
Retrieves a double property of the report for the model object.
(Inherited from ModelObject.) | |
GetReportProperty(String, Int32) |
Retrieves an integer property of the report for the model object.
(Inherited from ModelObject.) | |
GetReportProperty(String, String) |
Retrieves a string property of the report for the model object.
(Inherited from ModelObject.) | |
GetStringReportProperties |
Retrieves multiple string report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) | |
GetStringUserProperties |
Retrieves all string properties for the model object.
(Inherited from ModelObject.) | |
GetUserProperty(String, Double) |
Retrieves a double property for the model object.
(Inherited from ModelObject.) | |
GetUserProperty(String, Int32) |
Retrieves an integer property for the model object.
(Inherited from ModelObject.) | |
GetUserProperty(String, String) |
Retrieves a string property for the model object.
(Inherited from ModelObject.) | |
Insert |
Inserts the load temperature into the model database.
(Overrides ModelObjectInsert.) | |
Modify |
Modifies the existing load temperature in the model database to match the current one.
At the moment it is not possible to change the load attachment or the father.
(Overrides ModelObjectModify.) | |
Select |
Selects a load temperature from the model database. The ID must be set.
(Overrides ModelObjectSelect.) | |
SetDynamicStringProperty |
Sets a dynamic string property for the model object.
(Inherited from ModelObject.) | |
SetLabel |
Sets a label for an object when a new instance is created, this method must be called before Insert.
The label is used in plug-ins for identifying the changed object in modification.
(Inherited from ModelObject.) | |
SetPhase |
Sets the phase of the model object.
(Inherited from ModelObject.) | |
SetUserProperties |
Sets multiple properties for the model object.
(Inherited from ModelObject.) | |
SetUserProperty(String, Double) |
Sets a double property for the model object.
(Inherited from ModelObject.) | |
SetUserProperty(String, Int32) |
Sets an integer property for the model object.
(Inherited from ModelObject.) | |
SetUserProperty(String, String) |
Sets a string property for the model object.
(Inherited from ModelObject.) |
Examples
using System; using Tekla.Structures.Geometry3d; using Tekla.Structures.Model; public class Example { public void Example1() { LoadTemperature temperatureLoad = new LoadTemperature(); temperatureLoad.Position1 = new Point(0, 0, 0); temperatureLoad.Position2 = new Point(1000, 0, 0); temperatureLoad.BoundingBoxDx = 500; temperatureLoad.BoundingBoxDy = 500; temperatureLoad.BoundingBoxDz = 500; temperatureLoad.PartNames = Load.LoadPartNamesEnum.LOAD_PART_NAMES_INCLUDE; temperatureLoad.PartFilter = "example"; temperatureLoad.TemperatureChangeForAxialElongation = 1.0; temperatureLoad.TemperatureDifferentialSideToSide = 2.0; temperatureLoad.TemperatureDifferentialTopToBottom = 3.0; temperatureLoad.InitialAxialElongation = 4.0; if (!temperatureLoad.Insert()) { Console.WriteLine("Temperature load insert failed!"); } } }
See Also