IMateriaClientAdapterLoadGraph Method (Asset, ListGraphParameter) |
Loads the graph corresponding to the specified uri providing the explicit parameter values and retrieves it's GUID
Namespace: Tekla.Structures.TeklaStructuresInternal.MateriaClient
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
Parameters
- asset
- Type: Tekla.Structures.TeklaStructuresInternal.MateriaClientAsset
- graphParameters
- Type: System.Collections.GenericListGraphParameter
The list of parameters
Return Value
Type: TaskIGraphThe GUID of the loaded graph as a string, or empty string if the graph loading didn't succeed.
See Also