LinkFrameAttributes Class |
The LinkFrameAttributes class contains the attributes for controlling the appearance of
a link frame.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingGenericAttributesBase
Tekla.Structures.DrawingLinkFrameAttributes
Tekla.Structures.DrawingGenericAttributesBase
Tekla.Structures.DrawingLinkFrameAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
The LinkFrameAttributes type exposes the following members.
Constructors
Name | Description | |
---|---|---|
LinkFrameAttributes | Initializes a new instance of the LinkFrameAttributes class |
Properties
Methods
Name | Description | |
---|---|---|
GetAxisAlignedBoundingBox |
Gets the bounding box of the frame in the global axis coordinate system.
| |
GetObjectAlignedBoundingBox |
Gets the bounding box of the frame in the local coordinate system.
| |
IsEqual |
Compares the current object with an object of the same type.
(Overrides GenericAttributesBaseIsEqual(Object).) |
See Also