![]() | LinkAttributes Class |
The LinkAttributes class contains the attributes for controlling the appearance of a link.
![](/modules/custom/trimble_html_import/icons/SectionExpanded.png)
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
![](/modules/custom/trimble_html_import/icons/SectionExpanded.png)
The LinkAttributes type exposes the following members.
![](/modules/custom/trimble_html_import/icons/SectionExpanded.png)
Name | Description | |
---|---|---|
![]() | LinkAttributes |
Creates a new link attributes instance using standard attributes.
|
![]() | LinkAttributes(String) |
Creates a new link attributes instance loading the specified attributes.
|
![](/modules/custom/trimble_html_import/icons/SectionExpanded.png)
Name | Description | |
---|---|---|
![]() | Font |
Gets or sets the font attributes.
|
![]() | Frame |
Gets or sets the link frame attributes.
|
![]() | IsUnderlined |
Defines whether the link is underlined or not.
|
![]() | Scaling |
Gets or sets the link scaling options.
|
![](/modules/custom/trimble_html_import/icons/SectionExpanded.png)
Name | Description | |
---|---|---|
![]() | IsEqual |
Compares the current object with an object of the same type.
(Overrides AttributesBaseIsEqual(Object).) |
![]() | LoadAttributes |
Loads the link frame attributes from the specified file.
(Overrides AttributesBaseLoadAttributes(String).) |
![](/modules/custom/trimble_html_import/icons/SectionExpanded.png)
The following code shows how to load user-defined attributes that are named "red":
using Tekla.Structures.Drawing; public class Example { public void Example1() { LinkAttributes linkAttributes = new LinkAttributes("red"); } }
![](/modules/custom/trimble_html_import/icons/SectionExpanded.png)