LinkAttributes Class

The LinkAttributes class contains the attributes for controlling the appearance of a link.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class LinkAttributes : AttributesBase

The LinkAttributes type exposes the following members.

Constructors
  NameDescription
Public methodLinkAttributes
Creates a new link attributes instance using standard attributes.
Public methodLinkAttributes(String)
Creates a new link attributes instance loading the specified attributes.
Top
Properties
  NameDescription
Public propertyFont
Gets or sets the font attributes.
Public propertyFrame
Gets or sets the link frame attributes.
Public propertyIsUnderlined
Defines whether the link is underlined or not.
Public propertyScaling
Gets or sets the link scaling options.
Top
Methods
  NameDescription
Public methodIsEqual
Compares the current object with an object of the same type.
(Overrides AttributesBaseIsEqual(Object).)
Public methodLoadAttributes
Loads the link frame attributes from the specified file.
(Overrides AttributesBaseLoadAttributes(String).)
Top
Examples
The following code shows how to load user-defined attributes that are named "red":
using Tekla.Structures.Drawing;

public class Example
{
       public void Example1()
       {
           LinkAttributes linkAttributes = new LinkAttributes("red");
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next