LineTypesEnum Enumeration

The line types (the presentation of the line).

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
public enum LineTypesEnum
Members
  Member nameValueDescription
UndefinedLine0 The line type is undefined.
SolidLine1 The solid line (default).
DashedLine2 The dashed line (-----).
SlashedLine3 The slashed line (- - -).
DashDot4 The dash dotted line (--.--.).
DottedLine5 The dotted line (.....).
DashDoubleDot6 The dash double dotted line (-..-..-).
SlashDash7 The slash dash line (-- - -- -).
Custom9999 The custom line type (it will also transport the custom line type name)
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next