ParallelLineSegmentToLineSegment Method (LineSegment, LineSegment, Double) |
Returns true if the given line segments are parallel within the given angular tolerance.
Namespace: Tekla.Structures.Geometry3d
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
public static bool LineSegmentToLineSegment( LineSegment LineSegment1, LineSegment LineSegment2, double Tolerance )
Parameters
- LineSegment1
- Type: Tekla.Structures.Geometry3dLineSegment
The first line segment to be used. - LineSegment2
- Type: Tekla.Structures.Geometry3dLineSegment
The second line segment to be used. - Tolerance
- Type: SystemDouble
The angular tolerance (in radians) to be used.
Return Value
Type: BooleanTrue if the given line segments are parallel within the given tolerance.
See Also