LineLineAttributes Class |
The LineAttributes class is the attributes class of the line.
Inheritance Hierarchy
SystemObject
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingGraphicObjectGraphicObjectAttributes
Tekla.Structures.DrawingOpenGraphicObjectOpenGraphicObjectAttributes
Tekla.Structures.DrawingLineLineAttributes
Tekla.Structures.DrawingAttributesBase
Tekla.Structures.DrawingGraphicObjectGraphicObjectAttributes
Tekla.Structures.DrawingOpenGraphicObjectOpenGraphicObjectAttributes
Tekla.Structures.DrawingLineLineAttributes
Namespace: Tekla.Structures.Drawing
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
The LineLineAttributes type exposes the following members.
Constructors
Name | Description | |
---|---|---|
LineLineAttributes |
Creates a new default line attributes instance that loads standard attributes.
| |
LineLineAttributes(String) |
Creates a new line attributes instance that loads the specified attributes.
|
Properties
Name | Description | |
---|---|---|
Arrowhead |
The arrowhead attributes of the open graphic object. The end points of an open graphic object
can contain arrowheads.
(Inherited from OpenGraphicObjectOpenGraphicObjectAttributes.) | |
Line |
The line attributes of the graphic object. A graphic object always consists of lines.
(Inherited from GraphicObjectGraphicObjectAttributes.) |
Methods
Name | Description | |
---|---|---|
IsEqual |
Compares the current object with an object of the same type.
(Overrides AttributesBaseIsEqual(Object).) | |
LoadAttributes |
Loads the attributes from the attribute file.
(Overrides AttributesBaseLoadAttributes(String).) |
See Also