LibraryProfileItem Class

The LibraryProfileItem class contains information from library profiles in the catalog. Library profile items can be enumerated using a profile item enumerator.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Catalogs
Assembly:  Tekla.Structures.Catalogs (in Tekla.Structures.Catalogs.dll) Version: 2023.0.3
Syntax
public sealed class LibraryProfileItem : ProfileItem

The LibraryProfileItem type exposes the following members.

Constructors
  NameDescription
Public methodLibraryProfileItem
Creates a new library profile item instance.
Top
Properties
  NameDescription
Public propertyaProfileItemAnalysisParameters
An array list with the profile item analysis parameters.
Public propertyaProfileItemUserParameters
An array list with the profile item user parameters.
Public propertyProfileName
The profile item name.
Top
Methods
  NameDescription
Public methodCode exampleCopy
Copy the library profile item in the profile database to item with new name.
Public methodDelete
Deletes the profile item in the profile database.
Public methodModify
Modifies the profile item in the profile database.
Public methodSelect(String)
Selects the profile item in the profile database using the given name.
Top
Examples
It is possible to select a library profile item by its name:
using Tekla.Structures.Catalogs;

public class Example
{
       public void Example1()
       {
           LibraryProfileItem LibraryProfileItem = new LibraryProfileItem();
           LibraryProfileItem.ProfileName = "HEA300";
           LibraryProfileItem.Select();
           //Equivalent code:
           LibraryProfileItem LibraryProfileItem1 = new LibraryProfileItem();
           LibraryProfileItem1.Select("HEA300");
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next