LevelMark Constructor (ViewBase, Point, Point, LevelMarkLevelMarkAttributes)

Initializes a new instance of the LevelMark class using the given attributes.

Namespace:  Tekla.Structures.Drawing
Assembly:  Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
public LevelMark(
	ViewBase View,
	Point InsertionPoint,
	Point BasePoint,
	LevelMarkLevelMarkAttributes Attributes
)

Parameters

View
Type: Tekla.Structures.DrawingViewBase
The view where to insert the level mark.
InsertionPoint
Type: Tekla.Structures.Geometry3dPoint
The location where to place the level mark.
BasePoint
Type: Tekla.Structures.Geometry3dPoint
The location where to the level mark points.
Attributes
Type: Tekla.Structures.DrawingLevelMarkLevelMarkAttributes
The level mark attributes to be applied.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next