InvalidFilterExpressionException Class

The InvalidFilterExpressionException class represents an error that occurred during the expression evaluation. This class cannot be inherited.
Inheritance Hierarchy
SystemObject
  SystemException
    Tekla.Structures.FilteringInvalidFilterExpressionException

Namespace:  Tekla.Structures.Filtering
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class InvalidFilterExpressionException : Exception

The InvalidFilterExpressionException type exposes the following members.

Constructors
  NameDescription
Public methodInvalidFilterExpressionException(Expression, InvalidFilterExpressionExceptionReasonsType)
Initializes a new instance of the InvalidFilterExpressionException class.
Public methodInvalidFilterExpressionException(Expression, InvalidFilterExpressionExceptionReasonsType, Int32)
Initializes a new instance of the InvalidFilterExpressionException class.
Public methodInvalidFilterExpressionException(Expression, OperatorType, Expression, InvalidFilterExpressionExceptionReasonsType)
Initializes a new instance of the InvalidFilterExpressionException class.
Top
Properties
  NameDescription
Public propertyExpression
Gets the invalid expression.
Public propertyInvalidFilterExpressionExceptionReasonsType
Gets the reason why the exception is thrown.
Public propertyLeftExpression
Gets the invalid expression's left operand.
Public propertyOperatorType
Gets the invalid expression's operator.
Public propertyRightExpression
Gets the invalid expression's right operand.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next