OBBIntersects Method (OBB)

Tests if current OBB intersects with the given OBB

Namespace:  Tekla.Structures.Geometry3d
Assembly:  Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
public bool Intersects(
	OBB obb
)

Parameters

obb
Type: Tekla.Structures.Geometry3dOBB
OBB to test against

Return Value

Type: Boolean
True if the OBBs intersect, otherwise false
Exceptions
ExceptionCondition
ArgumentNullExceptionThrown when null is assigned to the obb parameter.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next