BinaryFilterExpressionCollectionInsert Method |
Inserts an element in the collection at a specified index.
Namespace: Tekla.Structures.Filtering
Assembly: Tekla.Structures (in Tekla.Structures.dll) Version: 2023.0.3
Syntax
Parameters
- Index
- Type: SystemInt32
The zero-based index at which the item shoud be inserted. - Item
- Type: Tekla.Structures.FilteringBinaryFilterExpressionItem
The item to insert. This value cannot be null.
Implements
IListTInsert(Int32, T)Exceptions
Exception | Condition |
---|---|
ArgumentNullException | Thrown when the supplied item is null. |
ArgumentException | Thrown when the supplied index is out of bounds. |
See Also