InputObjectDependencyAttribute Class |
The InputObjectDependencyAttribute class is used for storing an input object dependency which determines when the plug-in is updated in the system.
The attribute is initialized from the custom attribute [InputObjectDependency(PluginBase.InputObjectDependency Type)] in the plug-in source.
Inheritance Hierarchy
Namespace: Tekla.Structures.Plugins
Assembly: Tekla.Structures.Plugins (in Tekla.Structures.Plugins.dll) Version: 2023.0.3
Syntax
The InputObjectDependencyAttribute type exposes the following members.
Constructors
Name | Description | |
---|---|---|
InputObjectDependencyAttribute(Int32) |
The custom attribute [InputObjectDependency(PluginBase.InputObjectDependency Type)] uses this to store a dependency attribute which determines when the plug-in is updated in the system.
This is not to be used by itself.
| |
InputObjectDependencyAttribute(PluginBaseInputObjectDependency) |
The custom attribute [InputObjectDependency(PluginBase.InputObjectDependency Type)] uses this to store a dependency attribute which determines when the plug-in is updated in the system.
This is not to be used by itself.
|
Properties
See Also