InputItemInputTypeEnum Enumeration

Defines the type of the input.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
public enum InputTypeEnum
Members
  Member nameValueDescription
INPUT_1_POINT0 The input is one point. The data is returned as a point.
INPUT_2_POINTS1 The input is two points. The data is returned as an array list of points.
INPUT_POLYGON2 The input is any number of points (a polygon). The data is returned as an array list of points.
INPUT_1_OBJECT3 The input is one model object. The data is returned as a model object.
INPUT_N_OBJECTS4 The input is any number of model objects. The data is returned as an array list of model objects.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next