InputDefinitionFactory Class |
The InputDefinitionFactory class contains helper functions for input definition handling.
Inheritance Hierarchy
Namespace: Tekla.Structures.Drawing.Tools
Assembly: Tekla.Structures.Drawing (in Tekla.Structures.Drawing.dll) Version: 2023.0.3
Syntax
The InputDefinitionFactory type exposes the following members.
Constructors
Name | Description | |
---|---|---|
InputDefinitionFactory | Initializes a new instance of the InputDefinitionFactory class |
Methods
Name | Description | |
---|---|---|
CreateInputDefinition(TupleDrawingObject, ViewBase) |
Creates a single-object input definition.
| |
CreateInputDefinition(TuplePoint, ViewBase) |
Creates a single-point input definition.
| |
CreateInputDefinition(TuplePointList, ViewBase) |
Creates a multi-point input definition.
| |
CreateInputDefinition(ViewBase, DrawingObject) |
Creates a single-object input definition.
| |
CreateInputDefinition(ViewBase, PointList) |
Creates a multi-point input definition.
| |
CreateInputDefinition(ViewBase, Point) |
Creates a single-point input definition.
| |
CreateInputDefinition(ViewBase, Point, Point) |
Creates a two-point input definition.
| |
CreateInputDefinition(ViewBase, Point, Point, Point) |
Creates a three-point input definition.
| |
GetDrawingObject |
Gets the object from the given single-object input.
| |
GetPoint |
Gets the point from the given single-point input.
| |
GetPoints |
Gets the points from the given n-point input.
| |
GetView |
Gets the view that the given input belongs to.
|
Examples
using Tekla.Structures.Drawing; using Tekla.Structures.Drawing.UI; using Tekla.Structures.Drawing.Tools; using Tekla.Structures.Geometry3d; using Tekla.Structures.Plugins; public class Example { public void Example1() { var drawingHandler = new DrawingHandler(); Picker picker = drawingHandler.GetPicker(); var pick = picker.PickPoint("Pick a point"); var inputDefinition = InputDefinitionFactory.CreateInputDefinition(pick); ViewBase myView = InputDefinitionFactory.GetView(inputDefinition); Point myPoint = InputDefinitionFactory.GetPoint(inputDefinition); } }
See Also